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CLASS ID CP319398 

Innovative Designs and Procedural Patterns 
with Fusion 360 and Maya 
Alex Lobos – Rochester Institute of Technology 
Keqing Song – Autodesk 

 
Description 
Automation tools like generative design, visual programming and procedural nodes are 
transforming the way that products are created by providing design solutions that are efficient, 
resilient and visually striking.  When looking at the appearance created by these workflows, two 
types become evident. The first one resembles bones that provide structure with minimal use of 
material. The second one uses complex algorithmic patterns and procedural networks, similar to 
fractal geometries that can be used as bodies or applied to surfaces.  
 
This class explores easy-to-follow workflows for the creation and combination of procedural 
structures and patterns in product design. Designs can start in a typical modeling workflow 
within Fusion 360. Maya’s MASH tool will then be used to create intricate procedural networks, 
which are then brought into Fusion 360 for further refinement. The use of MASH is a novel and 
innovative approach, far easier to achieve than other tools such as Dynamo or Grasshopper, 
and with a completely different (yet complementary) process to Generative Design’s 
simulations. 
 
About the Speakers 
Alex Lobos is an industrial designer and educator focused in sustainable design, emotional 
attachment and CAD applications. He is Graduate Director and Professor and Industrial Design 
at Rochester Institute of Technology, New York. At Autodesk, Alex is a Fellow in-residence in 
Strategic Foresight, Expert Elite for Fusion 360, member of Autodesk University’s Advisory 
Council, AU Featured Speaker and recipient of Fusion 360’s Education Award. For more 
information on Alex’s work go to: https://www.rit.edu/artdesign/directory/aflfaa-alex-lobos 
 
Keqing Song is a Fusion 360 Product Manager. He first joined the Inventor Fusion team, and 
has been with the product since he started working at Autodesk 7+ years ago. Keqing has a 
mechanical engineering and business management background. He’s also a design geek, 
foodie, watch nerd, photography enthusiast, and vinyl junkie.  

Learning Objectives 
1. Learn how to use Fusion 360 to create a wide variety of designs, including using 

the Generative Design tool.  
2. Learn how to use Maya MASH to create procedural, algorithmic patterns and bring 

them into Fusion 360 for further development 
3. Learn about how to easily import and export geometries between Fusion 360 and 

Maya 
4. Learn how to generate innovative models that combine traditional CAD designs 

structures with intricate procedural patterns. 
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1 - Automation in digital design 
Automation is a key tool in CAD. It frees users from having to perform tasks that are either too 
complex or tedious.1 It also expands their capabilities to achieve results that are efficient, 
attractive, dynamic, and aligned with natural eco-systems.2 In both of these cases, automation 
provides results that would be hard to obtain without the use of technology. 
 
When using CAD tools in automated processes, there are two particular workflows that provide 
benefits in terms of how forms are created. On one hand is the use of procedural networks in 
order to create intricate patterns that resemble natural systems and have minimal use of 
geometric shapes.3 Second is the use of generative design tools, where sets goals and criteria 
are provided to a computer, which takes over and develops large number of iterations that meet 
such criteria.4 In both of these cases, humans and machines collaborate together and learn from 
each other as they create innovative design solutions.  
 
Fusion 360 is a powerful CAD tool that provides a user-friendly interface and a robust set of 
tools for design, fabrication, simulation and visualization. Recently Fusion 360 added to its 
platform the Generative Design tool, which allows users to set goals for physical performance of 
a given design, such as supporting forces and loads. Generative Design uses these goals and a 
basic input geometry to create large iterations of potential solutions, all meeting the set criteria. 
This is a very powerful workflow for design creation, but it also limits the user in terms of their 
control over physical appearance of the resulting designs.  
 
A complementary workflow to generative design is the use of procedural networks. This type of 
geometries provides a rich and intricate appearance, which can be edited to create interesting, 
progressive effects. In order to achieve these geometries, product designers use tools based in 
visual node patterns, typically Grasshopper and Dynamo. While these tools offer a wide range 
of capabilities and interesting outputs, they can be hard to learn for users without a strong 
foundation in coding and mathematical relations. This class proposes de use of Maya, 
particularly its plug-in MASH, as an alternative that is simpler to use. The key benefit of Maya-
MASH is that users do not need to create complex nodes from scratch but rather select from a 
series of preset patterns that are easy to tweak in order to achieve a desired procedural pattern. 
 
 
2 - Combining Fusion 360 and Maya 
The use of procedural networks in Maya/MASH that can be imported into Fusion 360 is a useful 
tool for creating complex patterns in a user-friendly way. The result are intricate patterns where 
the designer has a high degree of control and influence, which can be used as appearance 
details in product design.  

 
1 Gonçalo Castro, “TetraScript: A responsive pavilion, from generative design to automation,” Architectural 
Computing 1, no. 10 (2012): 87-104. 
2 Alex Lobos, “Finding Balance in Generative Product Design.” In Proceedings of Norddesign Conference: Design in 

the era of digitalization. 14-17 August, 2018. Linköping, Sweden. 
3 Alex Lobos, “Applying Generative Systems to Product Design.” In Proceedings of Generative Art Conference. 19-21 
December, 2019. Rome, Italy. 
4 Kristina Shea, et al. “Towards integrated performance-driven generative design tools,” Automation in Construction, 
14 (2005): 253-264. 
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The goal behind using procedural networks is to create design patterns that have a high degree 
of intricacy while still providing designers with enough flexibility to experiment with different 
aesthetic combinations. There are a number of existing workflows that have similar benefits, 
particularly Generative Design and Dynamo/Grasshopper. The combination of MASH/Fusion 
360 provides some key differences, and in general easier to achieve and execute (See Table 1).  
 

Differences between 
Generative Design and 
Fusion 360 + Maya 
workflows 

Procedural networks focus on creating interesting 
patterns that enhance product appearance 
instead of focusing on physical performance. 
 
The process gives designers ample control and 
flexibility in terms of combining different types of 
procedural nodes, and finetuning each of them in 
a direct way. In generative design, the role of the 
designer stays in setting up goals and in 
selecting outcomes, with limited input on how the 
new forms are generated. 
 

Differences between 
Dynamo/Grasshopper and 
Fusion 360 + Maya 
workflows 

Dynamo/Grasshopper require users to setup 
complex node networks ahead of time, and 
needs significant knowledge on the right 
terminology, node creation and algorithm 
relations. 
 
MASH, in contrast, offers a user-friendly interface 
that is based on preset nodes, each with 
variables that are easy to adjust via sliders. This 
workflow is a lot more intuitive and liberating to 
designers, as they can experiment with different 
patterns and shapes freely, until they find the 
design that feels more appropriate. 
 

Table 1: Differences between Fusion 360 + Maya workflows vs generative design or visual node patterns. 
 
Another benefit of using MASH is the ability to export files in a number of formats, particularly 
FBX. This file format creates bodies with a relatively low size, which can be imported easily into 
Fusion 360 and converted to B-Rep or T-Spline bodies. This easy conversion makes it possible 
to combine geometry originally created in Maya/MASH to be further edited in Fusion 360 and 
even to merge it with native bodies. 
 
 
3 - Typical workflows between Maya/MASH and Fusion 360. 
 
3.1 – Create freestanding network in MASH and import to Fusion 360.   
Process overview: Create network in MASH > Export as FBX > Import into Fusion 360 and 
convert to B-Rep or T-Spline.  
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Example (Figure 1): A box was replicated into a square grid, and then altered with a “noise” 
node to create a random effect. The result was imported from Maya into Fusion 360 and used 
as a decorative lamp. 
 

 
Figure 1: Table lamp concept  

 
3.2 – Attach MASH network to a body created in Fusion 360 (Figures 2, 3, 4). 
Process overview: Create geometry in Fusion 360 > Export as STL > Import into Maya and 
attach a MASH network to it > Export as FBX > Import into Fusion 360 and convert to B-Rep or 
T-Spline. 
Example (Figures 2-4): A Bluetooth speaker/lamp was designed in Fusion 360. The shade was 
then exported to Maya, where a series of procedural networks were attached to it. The resulting 
geometry was then imported back into Fusion 360. 

 

   
Figures 2, 3 and 4: A Bluetooth speaker/lamp. 

 
3.3 – Use a MAYA network to “stamp” a body in Fusion 360 
Process overview: Create network in MASH > Export as FBX > Import into Fusion 360 and 
convert to B-Rep or T-Spline > Use network to stamp (Boolean union, cut or intersect) a body 
created in Fusion 360. 
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Example (Figure 5): A network with a progressive pattern was created in Maya. The pattern 
was then brought into Fusion 360 and used as stamping tool for a detail portion of a chair. 
 

 
Figure 5: Chair detail 

 
 
4 - Tutorials 
Below are a set of tutorials that provide guidance on how to develop these workflows. This is not 
intended to be a comprehensive list of workflows but rather a starting point of directions so that 
designers and engineers start exploring possibilities between Fusion 360 and Maya. As with 
other modeling and visualization tools, the exploration and experimentation of tools is highly 
encouraged, in order to discover innovative and efficient ways of creating new designs.  
 
4.1 – Workflow 1: Creating a Procedural network in Maya  

Create 
base body 

In the top-tab “Poly 
Modeling”, select 
“Polygon Cube”. 
 
In the right-tab 
“Attribute Editor”, go 
to “PolyCube1”. Under 
“Poly Cube history” 
make sure that 
subdivisions are set 
to: W=1, H=1, D=1. 
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Create 
MASH 
network 

In the top-tab “MASH”, 
select “Create MASH 
network”. 

 
 

Edit 
MASH 
network 

In the right-tab 
“Attribute Editor”, go 
to “MASH1 Distribute”. 
 
Under “Distribute”, 
change the 
Distribution Type to 
“Grid” 
 
Adjust the distribution 
settings to: 
 
Distance X: 9 
Distance Y: 9 
Distance Z: 9 
Grid X: 10 
Grid Y: 10 
Grid Z: 10 
 

 

Add extra 
effects 

In the right-tab 
“Attribute Editor”, go 
to “MASH1”. 
 
>Feel free to explore 
different Nodes to 
achieve a wide variety 
of patterns. 
 
Click on “Signal” and 
select “Add Signal 
Node”. This should 
turn the cube grid into 
a random network. 
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 In the right-tab 
“Attribute Editor”, go 
to “MASH1_Signal”. 
 
>Scroll through 
different signal types 
in order to achieve 
various effects.  
 
Under “Signal Type”, 
select “4D Noise” and 
move the sliders 
under “Position”, 
“Rotation” and “Scale” 
to further edit the 
network. 
 

 

 
 
4.2 – Workflow 2: Importing a body into Maya and creating a network around it. 

Import STL In the top menu, go 
to:  
File > Import 
 
Select STL file. 

 
 

If the STL body is 
not visible, zoom 
out. 
 
In the left toolbar, 
select “Scale”. Click 
on the body and 
scale it down until it 
fits in the grid. 
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Create base 
body 

In the top-tab “Poly 
Modeling”, select 
“Polygon Cube”. 
 
In the right-tab 
“Attribute Editor”, go 
to “PolyCube1”. 
Under “Poly Cube 
history” make sure 
that subdivisions are 
set to: W=1, H=1, 
D=1. 
 

 

 
 

Create 
MASH 
network 

In the top-tab 
“MASH”, select 
“Create MASH 
network”. 

 
 

Add a 
distribution 
to the 
network 

In the right-tab 
“Attribute Editor”, go 
to “MASH1 
Distribute”. 
 
Right under 
“Distribution type”, 
make sure that 
“Center Distribution” 
is selected. 
 
  

 
Add a 
Transform 
Node 

In the right-tab 
“Attribute Editor”, go 
to “MASH1”. 
 
Click on “Transform” 
and select “Add 
Transform Node”.  
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Inside the 
“MASH1_Transform” 
tab, go to “Controller 
Null”, right-click and 
select “Create” 
 
The Transform node 
will be useful later 
for moving the 
network across the 
STL body. 
  

Add an 
Offset node 

In the right-tab 
“Attribute Editor”, go 
to “MASH1”. 
 
Click on “Offset” and 
select “Add Offset 
Node”.  
 

 
 

Inside 
“MASH1_Offset” 
tab, go to “Mode” 
and select “Closest 
Point to Mesh” 
 
Go to the left 
“Outliner” tab and 
look for the STL file. 
Using the mouse’s 
MIDDLE button, 
click-and-drag the 
STL file into: Closest 
Point on Mesh > 
Input Mesh.  
This action connects 
the MASH network 
to the STL surface. 
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Edit the 
Distribution 
type 

In the right-tab 
“Attribute Editor”, go 
to back to “MASH1 
Distribute”. 
 
Change the 
“Distribution type” to 
“Grid”.  
 
Adjust the 
distribution settings 
to: 
 
Distance X: 8 
Distance Y: 8 
Distance Z: 8 
Grid X: 8 
Grid Y: 8 
Grid Z: 8 

 
 

Move up 
the MASH 
network 

Go to the left 
“Outliner” tab and 
select the 
“Transform” locator.  
 
In the left-side 
toolbar, select the 
“Move” tool and use 
the arrows in the 
workspace to move 
up the MASH 
network.  
 
Once the network is 
in place, adjust 
“Distribution 
Settings” to obtain a 
desired coverage. 

 
 

Add extra 
effects 

In the right-tab 
“Attribute Editor”, go 
to “MASH1”. 
 
Click on “Signal” 
and select “Add 
Signal Node”. This 
should turn the cube 
grid into a random 
network running 
across the STL 
body. 
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In the right-tab 
“Attribute Editor”, go 
to “MASH1_Signal”. 
 
Under “Signal 
Type”, select 
“Fractional Brownian 
Motion” and move 
the sliders under 
“Position”, “Rotation” 
and “Scale” to 
further edit the 
network. 
 

 

 
4.3 – Workflow 3: Exporting a Procedural network as FBX 

Activate 
FBX plug-
in 

Make sure that you 
can export as FBX 
file: 
 
In the top menu, go 
to:  
Windows > 
Settings/Preferences 
> Plug-in Manager 
 
In the search window, 
type “fbx” and look for 
the “fbxExporter” 
plug-in. Make sure 
that “Loaded” and 
“Auto load” are 
selected. 
 

 
 

 
 

Export as 
FBX 

In the top menu, go 
to:  
File > Export All 
 
Type a name for the 
file, select location for 
saving it, and make 
sure that you select 
“FBX” as export type. 
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4.4 – Workflow 4: Importing a Procedural network into Fusion 360 
Creating 
the network 
in Maya 

In Maya, and Similar 
to Workflow 1, create 
a cube grid, and 
under “Distribute”, 
use the values below: 
 
Distance X: 15 
Distance Y: 15 
Distance Z: 15 
Grid X: 16 
Grid Y: 1 
Grid Z: 16 
 

 

Adding 
effects to 
the network 

In the right-tab 
“Attribute Editor”, go 
to “MASH1”. 
 
Click on “Influence” 
and select “Add 
Influence Node”. 
This should make 
the cubes scale 
up/down in relation 
to an influence point.   

 
 

In the right-tab 
“Attribute Editor”, go 
to 
“MASH1_Influence”. 
 
Play with the values 
“Power”, “Radius” 
and “Strength” to 
achieve the desired 
effect of influence. 

 
 

In the left-tab 
“Toolbar”, use 
“Move” to move the 
influence center 
point. 
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Preparing 
the network 
for Export 

In the top menu, go 
to Mesh >Separate, 
to break the grid into 
separate bodies. 

 
 

In the top menu, go 
to Mesh >Boolean 
>Union to join the 
bodies into a single 
component. 
 
This will make the 
grid behave as a 
single body when 
imported into Fusion 
360.  

 
Export 
network as 
FBX 

In the top Menu, go 
to File >Export All.  
 
Export the grid as an 
FBX file to your 
computer. 

 
 

Create a 
box in 
Fusion 360 

In Fusion 360, create 
a simple box and 
save the file.  
 
The FBX file will be 
used to “stamp” the 
pattern into this box.  
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Importing 
FBX into 
Fusion 360 

1- In Fusion 360’s 
application bar (top 
left area of the 
screen), go to the 
“data panel” icon and 
click to expand. 
 
2- In the data panel, 
click on the “upload” 
blue button and 
select the FBX file. 
 
3- After the file has 
been uploaded to the 
data panel, right-click 
on it and select 
“insert into current 
design”  
 

 

Break FBX 
link 

In the Browser (left 
side tree-structure), 
look for the FBX 
body, right-click and 
select “break link”. 
 
This selection will 
make it a stand-
alone body, without 
any link to the 
original file that was 
uploaded in the data 
panel. 

 

Stop 
capturing 
history 

In order to convert 
the FBX file into a B-
Rep body (so that it 
can be edited), it is 
necessary to stop 
Fusion 360 from 
capturing history. 
 
This will stop the 
model from being 
parametric. 
 
Go to the lower-right 
corner, click on the 
“gear” icon and 
select “do not 
capture design 
history” 
 

 

2 
1 

3 
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Convert to 
B-Rep 

Go back to the 
browser and look for 
the FBX’s file under 

“bodies”. 
 

Right-click and select 
“Mesh to B-Rep”.  

 
 

Add the 
pattern to 
the box 

Under “Modify”, use 
“Scale” and “Move” 
in order to make the 
pattern lay on top of 
the box. 
 
Make sure that the 
lower half of the 
pattern overlaps with 
the box. This will 
allow to create a 3D 
stamping effect on 
the box. 
 

 
 

Go to: Modify > 
Combine to create a 
Boolean operation 
between the two 

bodies.  
 

You can experiment 
with different 

operations such as 
“join” and “cut” 

 
 

 


